
ArtiSynth Installation Guide for Windows

John Lloyd and Sebastian Kazenbroot-Guppy
August 20, 2014



ArtiSynth Installation Guide for Windows 2

Contents

1 Introduction 4

2 Prerequisites 4

3 Downloading a Prepacked Release 4

3.1 Downloading and unpacking the zip file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

4 Checking out from Subversion 5

4.1 Checking out using Eclipse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

4.2 Checking out using TortoiseSVN . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

4.3 Checking out using Cygwin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

4.4 Downloading the libraries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

5 Building ArtiSynth 6

5.1 Building with Eclipse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

5.2 Building with Cygwin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

6 Running ArtiSynth 6

6.1 Running using artisynth.bat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

6.2 Running using Eclipse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

6.3 Running using Cygwin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

6.4 Testing the Demo Models . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

7 Installing External Models and Packages 7

7.1 Downloading . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

7.2 Building . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

7.3 Running . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

7.3.1 Adding external classes using the Eclipse Classpath . . . . . . . . . . . . . . . . . . . . . . . . . 8

7.3.2 Adding external classes using EXTCLASSPATH . . . . . . . . . . . . . . . . . . . . . . . . . . 8

7.3.3 Adding external classes using CLASSPATH . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

8 Updating ArtiSynth 8

8.1 Library updates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

9 The Eclipse IDE 9

9.1 Obtaining Eclipse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

9.2 Installing a Subversion plug-in . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

9.3 Importing an ArtiSynth project into Eclipse . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

9.4 Importing an ArtiSynth project directly from Subversion . . . . . . . . . . . . . . . . . . . . . . . . . . 10

9.5 Configuring environment variables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

9.5.1 Setting environment variables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

9.6 Adding projects to the build path . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

9.7 Adding projects to the ArtiSynth launch configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

9.8 Preventing excessive resource copying . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12



ArtiSynth Installation Guide for Windows 3

10 Additional Information 13

10.1 The TortoiseSVN Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

10.2 Cygwin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

10.3 Environment variables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

10.3.1 Setting environment variables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

10.3.2 The PATH environment variable . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

10.3.3 Typical environment settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

10.3.4 Cygwin environment settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

10.4 ArtiSynth Libraries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

10.5 The EXTCLASSPATH File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15



ArtiSynth Installation Guide for Windows 4

1 Introduction

This document describes how to install and run ArtiSynth on 64-bit Windows machines. There are two ways to
obtain ArtiSynth: downloading a prepackaged release, or checking out the latest development version via Subversion.
Downloading a prepackaged release is the easiest solution to simply try out some of the basic demo programs. Checking
out the development version is recommended for developers who want to keep their codebase current.

The typical install sequence looks like this:

Download Download either a release (Section 3) or check out the development version (Section 4).

Build Compile the system (Section 5). This step is not needed for prepackaged releases.

Run Start ArtiSynth and run the demonstration models (Section 6).

Generally, users will also want to install and run external models and packages that have been created either by others or
by themselves. This is discussed in (Section 7).

2 Prerequisites

To install ArtiSynth on Windows , you will need:

• A 64 bit version of Windows

• Java JDK 1.7

• Linux systems require GNU libc version 2.17 or higher

• A three button mouse is recommended for GUI interaction

Note that we have stopped supporting 32 bit systems, both because they are becoming obsolete, and because ArtiSynth
applications often require more memory than they can provide.

For Java, the full Java development kit (JDK) is required, which comes with the Java compiler javac. The run time
environment (JRE) will not be sufficient. However, there is no need for extra bundles such at JavaFX, NetBeans, or EE.

At the time of this writing, JDKs can be obtained free from Oracle at http://www.oracle.com/technetwork/java/javase/downloads/index.html.
We currently recommend either JDK 7 or 6. Note that JDKs are sometimes refered to by multiple names; for example,
JDK 6 is sometimes refered to as JDK 1.6.

In this document, the location of the ArtiSynth installation folder will be denoted by $ARTISYNTH_HOME. That means
that if ArtiSynth is installed in

C:\people\roger\artisynth_core

then $ARTISYNTH_HOME\lib denotes the folder

C:\people\roger\artisynth_core\lib

3 Downloading a Prepacked Release

3.1 Downloading and unpacking the zip file

To obtain one of the packaged distributions, go to www.artisynth.org/downloads and select the distribution you want.
Download it, and unzip it in an appropriate location on your computer.

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.artisynth.org/downloads
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Important:
On Windows , it is highly recommended that ArtiSynth is not installed in a location for which any of the folder
names contain spaces (i.e., Program Files). This can be important for some ArtiSynth programs to run correctly.

Once ArtiSynth is downloaded and unpacked, it should be possible to run it immediately by executing the artisynth.bat
file located in $ARTISYNTH_HOME\bin (see Section 6.1).

4 Checking out from Subversion

The latest development version is available from Subversion. Once checked out, users can continue to update the
codebase to keep it current (Section 8). Developers that we work with closely can also obtain, by mutual arrangement,
write access to our Subversion repository, allowing them to also commit changes.

The ArtiSynth Subversion URL is

https://svn.artisynth.org/svn/artisynth_core/trunk

Note:
If you omit the trailing /trunk from the Subversion URL, then the checkout will contain the entire Subversion
directory structure, including the subdirectories trunk, branches, and tags, which is generally not needed by
most users. Also, if you do check out the entire structure, the resulting trunk directory should be specified as
ARTISYNTH_HOME.

There are several ways to check out ArtiSynth using its Subversion URL:

4.1 Checking out using Eclipse

If you are planning to develop ArtiSynth models in Java, and if you are planning to do this with Eclipse (Section 9), then
it might be easiest to do the Subversion checkout directly in Eclipse. Follow the instructions in Section 9.4, using the
ArtiSynth Subversion URL (above) as the Subversion_url.

4.2 Checking out using TortoiseSVN

You can also use a Subversion client to check out ArtiSynth. Follow the instructions in Section 10.1, using the ArtiSynth
Subversion URL (above) as the Subversion_url.

4.3 Checking out using Cygwin

If you have Cygwin (Section 10.2) installed, along with the svn package, then you can check out ArtiSynth using the
following Cygwin terminal command:

> svn co https://svn.artisynth.org/svn/artisynth_core/trunk artisynth_core

This will check out ArtiSynth and place it in the specified folder (in this case artisynth_core).

4.4 Downloading the libraries

Because the jar files and native libraries used by ArtiSynth are large, they are not stored in the Subversion repository.
Instead, they must be downloaded separately. This can be done using the command updateArtisynthLibs.bat,
located in $ARTISYNTH_HOME\bin. You can execute it by double-clicking on it in a file-browser, or by opening a
command interpreter (CMD), navigating to $ARTISYNTH_HOME, and entering the command

% bin\updateArtisynthLibs

If you have Cygwin (Section 10.2) installed, the same command is available as updateArtisynthLibs, also located in
$ARTISYNTH_HOME\bin.
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5 Building ArtiSynth

If ArtiSynth has been obtained directly from Subversion, it will be necessary to build (compile) it. This is not necessary
for prepackaged releases, which are pre-built, although one may want to rebuild a release anyway for development
purposes.

5.1 Building with Eclipse

If your Subversion checkout has been done externally to Eclipse (i.e., not according to Section 4.1), then you need to
first import ArtiSynth into Eclipse. Follow the instructions in Section 9.3.

Once ArtiSynth has been imported, you should be able to build it. If necessary, first open a Java perspective by choosing
Window > Open Perspective > Java. The project artisynth_core (or whatever you might have named it) should appear
in the Package Explorer window. To build the system, select the project in the Package Explorer window, and then
choose Project > Build Project. Note that it may be necessary to deselect Build Automatically in order to enable Build
Project.

5.2 Building with Cygwin

If you have Cygwin (Section 10.2) installed, ArtiSynth can also be built from a Cygwin terminal by running a make
command in the top level folder . Before doing this, you need to first set the environment variables ARTISYNTH_HOME
and CLASSPATH as described in Sections 10.3 and 10.3.4. ArtiSynth can then be built by executing

> cd $ARTISYNTH_HOME
> make

6 Running ArtiSynth

6.1 Running using artisynth.bat

The most direct way to start ArtiSynth is to run the batch file artisynth.bat, located in $ARTISYNTH_HOME\bin. This
can be done by double-clicking on it in a file browser.

You can also create a shortcut to this batch file (by right clicking on it and selecting Create Shortcut), and then
placing this shortcut in either the START menu or on the Desktop. However, the batch file itself must remain in
$ARTISYNTH_HOME\bin.

Alternatively, you can open a command interpreter (CMD), navigate to $ARTISYNTH_HOME, and enter the command

% bin\artisynth

Note:
If Java is installed in a non-conventional location, the system may not be able to find it and this will cause
artisynth.bat to fail. To fix this, locate the folder in which java.exe resides, and let the location of this
folder be called JAVA_DIR. You should then add JAVA_DIR to your system’s PATH environment variable (see
Section 10.3.2).

6.2 Running using Eclipse

Once ArtiSynth has been imported into Eclipse (and built if necessary), it should contain a launch configuration called
ArtiSynth that will allow ArtiSynth to be run.

Generally, it is first necessary set environment variables in the launch configuration to allow ArtiSynth to find runtime
configuration files and libraries. Instructions for setting these variables are contained in Section 9.5. If the same
environment variables have already been set externally in Windows (Sections 10.3.1 and 10.3.3), then they do not need
to be set in the launch configuration.

Once the environment variables are set, it should be possible to run ArtiSynth by choosing Run > Run.
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Figure 1: The ArtiSynth play controls. From left to right: step size control, current simulation time, and the reset, play/-
pause, and single-step buttons.

6.3 Running using Cygwin

If you have Cygwin (Section 10.2) installed, then you can run ArtiSynth directly with the artisynth command located
in $ARTISYNTH_HOME/bin:

> cd $ARTISYNTH_HOME
> bin/artisynth

If $ARTISYNTH_HOME/bin has been placed in your PATH variable (Section 10.3), then it is sufficient to do

> artisynth

artisynth can be called with a number of options; to see these, run

> artisynth -help

6.4 Testing the Demo Models

Once ArtiSynth starts up, you can try out the various demonstration models. From the menu bar, Select Models >
Demos. This will display a submenu of demonstration models. Choosing one will cause that model to be loaded and
displayed in the viewer. Simulation of the model can then be started, paused, single-stepped, or reset using the play
controls (Figure 1) located at the upper right of the ArtiSynth window frame.

Comprehensive information on exploring and interacting with models is given in the ArtiSynth User Interface Guide.

7 Installing External Models and Packages

Typically, an ArtiSynth developer will want to use external models and packages that exist outside of artisynth_core.
Some of these may be obtained from external sources. For example, artisynth_models is a collection of packages,
currently hosted at www.artisynth.org/models, that provides a variety of publicly available anatomical models.

Installing external models and packages requires a sequence of operations similar to that for installing ArtiSynth itself:

1. Download

2. Build (if necessary)

3. Run

7.1 Downloading

Some model and package collections, such as artisynth_models mentioned above, may be available either as
prepackaged distributions or as Subversion checkouts. Prepackaged distributions should be downloaded and unpacked
into a desired location, while Subversion checkouts may be obtained as described in Section 4, using the appropriate
Subversion URL in place of the ArtiSynth Subversion URL. Some collections require authorization for checkout. In
those cases, it will be necessary to also provide Subversion with an account name and password (which you will have
obtained from us by prior arrangement).

Some collections maintained by ArtiSynth may contain Eclipse project settings (in an eclipseSettings.zip file in
their root folder ), allowing them to be imported into Eclipse, either directly from Subversion (Section 9.4), or after
being obtained separately (Section 9.3).

http://www.artisynth.org/doc/html/uiguide/uiguide.html
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7.2 Building

Collections that are obtained from Subversion will need to be built (compiled).

Those imported into Eclipse can be built as described in Section 5.1. However, in order to compile properly, the
artisynth_core project (and any other projects they depend on) were have to be added to their build path. Details on
doing this are given in Section 9.6.

Alternatively, if the collection has a Makefile in its root folder , then it can be compiled from a Cygwin terminal by
running make in the root folder . Before doing this, the top-level directory for the collection’s class files must to be
added to the CLASSPATH environment variable (Sections 10.3 and 10.3.4). In collections maintained by ArtiSynth, this
will be the directory classes, located directly under the collection root directory (e.g., artisynth_models\classes).

7.3 Running

External models are executed by running ArtiSynth itself (Section 6). However, in order to execute these models,
ArtiSynth must be able to locate their associated classes. This can be arranged in three different ways:

7.3.1 Adding external classes using the Eclipse Classpath

If you are running from Eclipse, then you can make the classes of external projects visible to ArtiSynth by adding the
projects to the Classpath of your ArtiSynth launch configuration, as described in Section 9.7.

7.3.2 Adding external classes using EXTCLASSPATH

Alternatively, you can make the classes of external projects visible to ArtiSynth by adding the path names of all their
top-level class folders (or jar files, if relevant) to the file $ARTISYNTH_HOME\EXTCLASSPATH (described in Section
10.5).

For example, suppose the collection artisynth_models has been placed in C:\projects\artisynth_models. The
top-level class folder for this collection is located in artisynth_models\classes, and so the following entry should be
placed in the EXTCLASSPATH file:

C:\projects\artisynth_models\classes

7.3.3 Adding external classes using CLASSPATH

Finally, if you are running using artisynth.bat (or artisynth in Cygwin), then you can make external classes visible
by adding them to your CLASSPATH environment variable (see Sections 10.3 and 10.3.4).

8 Updating ArtiSynth

One reason to use a checkout of the latest ArtiSynth development version is to be able to migrate recent changes into
your code base. When a significant update occurs, a posting is made to the ArtiSynth update log, currently located at
www.artisynth.org/doc/html/updates/updates.html. Users may also be notified via the artisynth-updates email list.

Users working from Eclipse with a Subversion plug-in installed (Section 9.4) may update simply by selecting the project
in the Package Explorer and selecting Team > Update from the context menu.

Updating may also be done using a Subversion client program (such as TortoiseSVN, Section 10.1), or from a Cygwin
terminal, by running the command

svn update

in the ArtiSynth installation folder .

http://www.artisynth.org/doc/html/updates/updates.html
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8.1 Library updates

Occasionally, a software update will be accompanied by a change in the libraries located in $ARTISYNTH_HOME\libs.
When this happens, it will be indicated on the ArtiSynth update log and appropriate instructions will be given. Some-
times, it will be necessary to explicitly update the libraries after doing the main update. This can be done by executing
updateArtisynthLibs as described in Section 4.4.

9 The Eclipse IDE

Eclipse is an integrated development environment (IDE) commonly used for Java code development, and many
ArtiSynth developers use it for both programming models and for running the system. This section describes how to
load ArtiSynth projects into Eclipse, and how to configure it for running ArtiSynth. A general introduction to Eclipse is
beyond the scope of this document, but there are many Eclipse resources available online.

9.1 Obtaining Eclipse

Eclipse can be obtained from www.eclipse.org/downloads. A good version to obtain (at the time of this writing) is
Eclipse IDE for Java Developers.

9.2 Installing a Subversion plug-in

In order to work with Subversion from within Eclipse, either to check out ArtiSynth from the repository, or to update or
commit changes, it is necessary to use a Subversion plug-in. First, check to see if your version of Eclipse contains an
Subversion plug-in:

Open an import panel using File > Import..., and then look for SVN in the set of available import sources. If you don’t
see SVN listed, it will be necessary to install a plug-in.

We recommend the Eclipse-supported Subversive plug-in, but if this proves difficult for any reason, there are other
options, such as Subclipse, currently obtainable from subclipse.tigris.org.

Instructions for installing Subversive can be obtained at www.eclipse.org/subversive/installation-instructions.php.

One way to install Subversive is through the Eclipse Marketplace. If you have an older version of Eclipse that doesn’t
have Marketplace, you may be able to obtain it from www.eclipse.org/mpc. To access the Marketplace, click Help >
Eclispe Marketplace. Once the available applications have been displayed, type Subversive into the Find box in the
top-left corner of the Marketplace window. Navigate to the package labeled Subversive - SVN Team Provider and click
Install. On the Confirm Selected Features screen, ensure all boxes are checked and click the button labeled Confirm >.
Restart Eclipse when prompted.

One more step is now necessary. Re-open Eclipse, and you should be prompted to choose an SVN connector in the start
menu. SVN connectors interface Subversive to the SVN server, and are OS and server-specific. A recommended SVN
Connector will be pre-selected for downloading; this is most likely the one you need.

If Eclipse did not prompt you to choose a connector when it restarted, you can install SVN connectors separately (thanks
to bmaupin at Stackoverflow for this information):

1. Go to www.polarion.com/products/svn/subversive/download.php

2. Under the latest Release, copy the Subversive SVN Connectors URL. The current URL for Eclipse 4.3 Kepler is
http://community.polarion.com/projects/subversive/download/eclipse/3.0/kepler-site.

3. In Eclipse, go to Help > Install New Software... and click Add...

4. Copy the URL for the Subversive SVN Connectors into the Location box and click OK

5. Check Subversive SVN Connectors, click Next, and then follow the instructions to complete installation.

If in doubt about the connector you need, you can install multiple ones, and then adjust the one Subversive actually uses
by going to Windows > Preferences, opening Team > SVN, and then opening the SVN Connector tab.

http://www.eclipse.org/downloads
http://subclipse.tigris.org/servlets/ProjectProcess?pageID=p4wYuA
http://www.eclipse.org/subversive/installation-instructions.php
http://www.eclipse.org/mpc/
http://www.polarion.com/products/svn/subversive/download.php
http://community.polarion.com/projects/subversive/download/eclipse/3.0/kepler-site/
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9.3 Importing an ArtiSynth project into Eclipse

An ArtiSynth project can be either ArtiSynth itself, or an associated project containing specific modeling applications.
Let $PROJECT_ROOT denote the project root folder . For ArtiSynth itself, this will be $ARTISYNTH_HOME.

1. From outside Eclipse, install the Eclipse settings by unzipping $PROJECT_ROOT\eclipseSettings.zip into
$PROJECT_ROOT. This will create the files .project and .classpath, along with the folder .settings, in
$PROJECT_ROOT. For ArtiSynth itself, it will also create the file ArtiSynth.launch containing the launch
configuration.

2. From within Eclipse, choose File > Import ....

3. In the Import window, select General > Existing Projects into Workspace and click Next.

4. In the field Select root directory, enter (or browse to) $PROJECT_ROOT and then click Finish.

If Eclipse complains that "No projects are found to import", that most likely means that eclipseSettings.zip was not
properly unzipped into $PROJECT_ROOT.

9.4 Importing an ArtiSynth project directly from Subversion

If Eclipse has a Subversion plug-in installed (Section 9.2), you may import an ArtiSynth project by checking it out
directly from the repository located by the project’s Subversion_URL. For the core ArtiSynth distribution, this is

https://svn.artisynth.org/svn/artisynth_core/trunk

Other projects will have different URLs.

The following instructions assume the Subversive plug-in.

1. Choose File > Import from the main menu, select SVN > Project from SVN and click Next.

2. You now need to specify a repository location, as specified by a Subversion_URL. If you’ve previously done an
SVN checkout, a menu will appear allowing you to select a previously used URL. If one of these is sufficient,
select it and click Next to go to Step 4. Otherwise, select Create a new repository location and click Next to enter a
repository dialog. If no previous locations are known this dialog will appear automatically.

3. If you are specifying a new location in the repository dialog:

• Under the General tab, enter the Subversion_URL in the URL box. If you are just checking out the trunk of the
repository (i.e., if your Subversion URL ends in /trunk), then you should omit the final /trunk since this is
selectable in Step 4.

• If you are checking out a repository that is not available for anonymous access, or if you need write access to
the repository, enter your ArtiSynth User ID and Password (which you will have obtained from us separately) in
the Authentication section of the dialog. You will probably want to check Save authentication as well.

• Click Next.

4. In the Select Resource dialog, use the URL selector box to select the full URL to be used for the checkout. If you
are just checking out the trunk of the repository, then choose Subversion_URL/trunk which should be available
as a selection.

5. Click Finish

6. In the Check Out As dialog, select Check out as a project with name specified, adjust the project name if desired,
and click Next.

7. Specify the location for the check out. If you leave Use default workspace location selected, this will be
workspace/project_name, where workspace is the Eclipse workspace folder and project_name is the
project name selected in the previous step. Otherwise, you can specify an explicit checkout location (which does
not have to be located in the Eclipse workspace). For ArtiSynth core checkouts, the project name is typically
artisynth_core and the the checkout location will become the ArtiSynth install folder $ARTISYNTH_HOME.
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8. Click Finish.

9. If necessary, open a Java perspective by choosing Window > Open Perspective > Java. The project should appear
in the Package Explorer window.

10. From outside Eclipse, install the Eclipse settings by unzipping $PROJECT_ROOT\eclipseSettings.zip into
$PROJECT_ROOT. This will overwrite the file .project, and create the file .classpath, along with the folder
.settings, in $PROJECT_ROOT. For ArtiSynth itself, it will also create the file ArtiSynth.launch containing the
launch configuration.

Note: if unzip queries about overwriting .project, answer [y]es.

11. From outside Eclipse, download the required jar files and native libraries as described in Section 4.4.

12. Finally, load the new settings into the project by selecting the project in the Package Explore window and
selecting Refresh from the context menu.

9.5 Configuring environment variables

To run ArtiSynth from Eclipse, it is generally necessary to set certain environment variables directly in your Eclipse
launch configuration so that ArtiSynth can locate configuration files and native library support. Directions on setting the
environment variables are given in Section 9.5.1. The required settings are:

• Set ARTISYNTH_HOME to the path of the ArtiSynth installation folder .

• Set PATH to $ARTISYNTH_HOME\lib\Windows64

• Optionally, set OMP_NUM_THREADS (see Section 10.3).

• Optionally, set ARTISYNTH_PATH (see Section 10.3).

If any of the above variables have already been set externally in Windows (Sections 10.3.1 and 10.3.3), then they do not
need to be set in the launch configuration.

Note: At present, eclipse does not expand environment variables. In all the variable settings described below,
references to $ARTISYNTH_HOME should be expanded (manually) to the path of the ArtiSynth install folder .

Note: There is a bug in Eclipse 4.0+ on Windows where it will replace the system’s na-
tive %PATH% variable rather than appending to it. To correct this behaviour, define PATH as
${env_var:path};$ARTISYNTH_HOME\lib\Windows64

9.5.1 Setting environment variables

To set environment variables within Eclipse:

1. Open a java perspective if necessary by choosing Window > Open Perspective > Java.

2. Select the ArtiSynth project in the Package Explorer form.

3. Choose Run > Run Configurations... to open the Run Configurations window.

4. In the left panel, under Java Application, select ArtiSynth.

5. In the right panel, select the environment tab.

6. To create a new environment variable, click the New button and enter the name and value in the dialog box.

7. When finished, make sure that Append environment to native environment is selected, and click Apply.
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9.6 Adding projects to the build path

A project imported into Eclipse may depend on the packages and libraries found in other projects to compile prop-
erly. For example, ArtiSynth applications which are external to artisynth_core will nonetheless depend on
artisynth_core. To ensure proper compilation, project dependencies should be added to each dependent project’s
build path.

1. Select the dependent project in the Package Explorer form.

2. Right click and choose Build Path > Configure Build Path...

3. In the right panel, select the Projects tab.

4. Click the Add button, select the project dependencies, and click OK

5. Click OK in the Java Build Path panel

9.7 Adding projects to the ArtiSynth launch configuration

The classes of external projects can be made visible to ArtiSynth by adding the projects to the Classpath of the Ar-
tiSynth launch configuration.

1. From the main menu, choose Run > Run Configurations... to open a Run Configurations dialog.

2. In the left panel, under Java Application, select your ArtiSynth launch configuration (the default one is called
ArtiSynth). This may already be selected when you open the panel.

3. In the right panel, select the Classpath tab.

4. In the Classpath: window, select User Entries, and then click the Add Projects button.

5. In the Project Selection dialog, select the external projects that you wish to add. Generally, the boxes Add
exported entries ... and Add required projects ... can be unchecked. Click OK.

6. Close the Run Configurations dialog.

9.8 Preventing excessive resource copying

By default, ArtiSynth classes are built in a directory tree ($PROJECT_ROOT\classes) that is separate from the source
tree ($PROJECT_ROOT\src), where $PROJECT_ROOT denotes the project root folder and is $ARTISYNTH_HOME for
ArtiSynth itself. That means that Eclipse will try to copy all non-Java files and folders from the source tree into the build
tree. For ArtiSynth, this is excessive, and results in many files being copied that don’t need to be, since ArtiSynth looks
for resources in the source tree anyway.

It is possible to inhibit most of this copying:

1. Choose Window > Preferences (or Eclipse > Preferences).

2. Select Java > Compiler > Building.

3. Open Output folder, and in the box entitled Filter resources, enter the string:

Makefile ,*.a*,*.b*,*.c,*.cc ,*.cxx ,*.e*,*.g*,*.h*,*.i*,*.m*,*.n*,*.o*,*.r*,*.s ←↩
*,*.t*

That should filter out the copying of most non-java files.

Or, to prevent copying any resource, simply enter:

*
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10 Additional Information

10.1 The TortoiseSVN Client

In some cases, a user-interface may be preferable to the command line for interfacing with Subversion. The preferred
solution for Windows is to use TortoiseSVN, which can be acquired from tortoisesvn.net. On that website, navigate to
Downloads and then select the package appropriate for your operating system (which presumably will be 64-bits).

Once downloaded, run the MSI installer and follow the instructions in the installer. When the download completes,
right-clicking in any file browser in Windows should now present you with SVN version control options, analogous to
the command line instructions discussed in other parts of the documentation. We will briefly discuss here the three most
common operations:

Checking out a repository To check out an SVN repository with TortoiseSVN, right-click in any file exploration
window and select SVN Checkout... from the context menu. The current directory will be the default directory
for the Checkout directory field, and the Subversion_URL can be selected in the URL of repository field. It is
recommended that other fields remain as their default values.

Updating a working copy While inside a working copy of a repository in a file browser window, updating that
repository is as simple as right-clicking and selecting SVN Update.

Committing changes Users which have write-access to a repository may commit changes that they have made.
Right-click in a file browser window inside a working copy of a repository and select Commit.... Write a commit
message and the select OK.

10.2 Cygwin

Cygwin provides Windows users with a Linux-like, shell-based command environment. Its provides useful tools
and enables ArtiSynth users to employ all the script-based commands in $ARTISYNTH_HOME\bin, as well as various
Makefile commands.

Cygwin can be downloaded from www.cygwin.com. Run the executable that was just downloaded (setup.exe) to begin
installation. After selecting a download source, an install directory, a package directory, an internet connection, and a
download site, the installer will display a list of packages which the user can select for download. Normally, a default set
of packages is already selected for installation. It is advisable to install these packages to ensure that Cygwin retains its
basic capabilities. It is also recommended that you select the following additional packages:

• archive

• asciidoc, svn, make (located under devel)

• python (located under interpreters).

• openssh (located under net)

If you are planning to compile C/C++ code, you may also want to install the various gcc and gdb packages (located
under devel).

10.3 Environment variables

This is a glossary of all the environment variables that are associated with building or running ArtiSynth. Often, the sys-
tem can detect and set appropriate values for these automatically. In other cases, as noted in the above documentation, it
may be necessary or desirable for the user to set them explicity.

ARTISYNTH_HOME
The path name of the ArtiSynth installation folder .

http://tortoisesvn.net
http://www.cygwin.com
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ARTISYNTH_PATH
A list of folders , separated by semi-colons ";", which ArtiSynth uses to search for configuration files such as
.artisyntInit or .demoModels. A typical setting for ARTISYNTH_PATH consists of the current folder (indicated
by "."), the user’s home folder , and the ArtiSynth installation folder . If ARTISYNTH_PATH is not defined
explicitly in the user’s environment, ArtiSynth assumes an implicit path consisting of the folder sequence just
described.

CLASSPATH
A list of folders and/or jar files, separated by semi-colons ";", which Java uses to locate its class files. This
variable should be set to include $ARTISYNTH_HOME\classes and $ARTISYNTH_HOME\lib\* (the latter uses the
wildcard * to specify all the jar files in $ARTISYNTH_HOME\lib).

PATH
A list of folders , separated by semi-colons ";", which the operating system uses to locate executable programs and
applications. This should be set to include $ARTISYNTH_HOME\bin and $ARTISYNTH_HOME\lib\Windows64 .
This variable is described in detail in Section 10.3.2.

OMP_NUM_THREADS
Specifies the maximum number of processor cores that are available for multicore execution. Setting this variable
to the maximum number of cores on your machine can significantly increase performance.

Note that settings for most of the above can be derived from the value of ARTISYNTH_HOME.

10.3.1 Setting environment variables

On Windows, a user can view, set, or change environment variables via the following steps:

1. Right-click My Computer, and then click Properties.

2. Click the Advanced tab.

3. Click Environment variables.

4. Choose one of the following options:

• Click New to add a new variable name and value.
• Click an existing variable, and then Edit to change its name or value.
• Click an existing variable, and then Delete to remove it.

Variable settings can reference other environment variables, by surrounding them with percent signs, as in %VARIABLE_NAME%.
For example, suppose you already have an environment variable HOME that gives the location of your home folder , and
your ArtiSynth distribution is located in packages\artisynth_core relative to your home folder . Then the environ-
ment variable ARTISYNTH_HOME can be specified as

%HOME%\packages\artisynth_core

10.3.2 The PATH environment variable

The special environment variable PATH tells the system where to find applications and programs. It consists of a
list of folder names separated by semicolons ";". If you have applications or programs that reside in non-standard
locations, you can enable the system to find them by adding their containing folder to the existing PATH value. For
example, the programs associated with ArtiSynth reside in $ARTISYNTH_HOME\bin. If ARTISYNTH_HOME has the value
"C:\packages\artisynth_core", then the ArtiSynth programs can be made visible to the system by setting PATH to

%PATH%;c:\packages\artisynth_core\bin

Alternatively, if the ArtiSynth home location is described by the environment variable ARTISYNTH_HOME, then the above
can be expressed as

%PATH%;%ARTISYNTH_HOME%\bin

Note that most programs and applications need to be restarted in order to get them to notice changes to the PATH.
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10.3.3 Typical environment settings

Typical settings for the environment variables described above might look like this:

ARTISYNTH_HOME c:\users\joe\artisynth_core
ARTISYNTH_PATH .;c:\users\joe;%ARTISYNTH_HOME%
CLASSPATH %ARTISYNTH_HOME%\classes;%ARTISYNTH_HOME%\lib\*
PATH %ARTISYNTH_HOME%\bin;%ARTISYNTH_HOME%\lib\Windows;%PATH%
OMP_NUM_THREADS 2

10.3.4 Cygwin environment settings

When running a Cygwin terminal, it is possible to set environment variables in the startup script for the terminal’s shell.
Assuming that this shell is bash, then the environment settings described in 10.3.3 can be set by inserting the following
into one of bash’s initialization files (typically ~/.bashrc):

# set AH to the location of the ArtiSynth install folder
AH=$HOME/artisynth_core
export PATH=$AH/bin:$AH/lib/Windows64:$PATH

# Use Windows path style for ARTISYNTH_HOME , ARTISYNTH_PATH , and CLASSPATH:
export ARTISYNTH_HOME=‘cygpath -w $AH‘
export ARTISYNTH_PATH=".;‘cygpath -w $HOME ‘;$ARTISYNTH_HOME"
export CLASSPATH="$ARTISYNTH_HOME\classes;$ARTISYNTH_HOME\lib"’\*;’"$CLASSPATH"
export OMP_NUM_THREADS=2

Note that even on Cygwin, the environment variables ARTISYNTH_HOME, ARTISYNTH_PATH, and CLASSPATH should be
set using Windows path conventions. That is because they may not necessarily be invoked in a Unix-like context.

10.4 ArtiSynth Libraries

ArtiSynth uses a set of libraries located under $ARTISYNTH_HOME\lib. These include a number of jar files, plus native
libraries located in architecture-specific sub-folders (Windows64 for 64-bit Windows systems).

As described in Section 4.4, these libraries need to be downloaded automatically if the system is obtained from the
Subversion repository. The required libraries are listed in the file $ARTISYNTH_HOME\lib\LIBRARIES. This file is
checked into the repository, so that the system can always determine what libraries are needed for a particular checkout
version.

Occasionally the libraries are changed or upgraded. If you run ArtiSynth with the -updateLibs command line option,
the program will ensure that not only are all the required libraries present, but that they also match the latest versions on
the ArtiSynth server.

10.5 The EXTCLASSPATH File

In order to run an external model or package in ArtiSynth, all class paths (i.e., class folders or jar files) associated with
those external classes must be made visible to ArtiSynth. One way to do this is to list these class paths as entries in the
text file EXTCLASSPATH, located in $ARTISYNTH_HOME.

To add class paths to EXTCLASSPATH, open it using a standard text editor (such as Notepad) and add each required path.
For clarity, each path is typically added on a separate line. However, multiple paths can be added on the same line if they
are separated by the path separator character used for that OS.

The syntax rules for EXTCLASSPATH are:

1. Class path entries on the same line should be separated by a path separator character (a semi-colon ’;’ for
Windows and a colon ’:’ for MacOS and Linux).

2. The # character comments out all remaining characters to the end of line.

3. The $ character can be used to expand environment variables.
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4. Any spaces present will be included in the path name.

An example EXTCLASSPATH might look like this:

C:\research\artisynth_models\classes
C:\research\models\special.jar
$HOME\projects\crazy\classes
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