ArtiSynth Installation Guide for Linux

2 Prerequisites

To install ArtiSynth on Linux, you will need:

  • A 64 bit version of Linux.

  • Java 8 (see Section 4).

    ArtiSynth will generally work with later versions of Java, but Java 8 currently provides maximum compatibility with MATLAB, which still uses Java 8.

  • Linux systems require GNU libc version 2.17 or higher.

  • A three-button mouse is useful for GUI interaction.

  • A machine with a good graphics card and a decent amount of memory. We recommend 16 Gbytes, or more if you are doing FEM analysis with larger numbers of elements.